Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2019-10-21 18:48:35

Hala
Contributor
Registered: 2019-09-11
Posts: 3

[SOLVED] Flashing to newest firmware issue

Hello...

I was trying to to flash the PM to the newest  version from RRG\iceman repo,  however I got the following:

[!!] Note: Your bootloader does not understand the new CHIP_INFO command           
[!!] It is recommended that you first update your bootloader alone,           
[!!] reboot the Proxmark3 then only update the main firmware 

After searching, I tried flashing the booloader alone and it was successful. However, when I tried running the client I got:


 unknown command:: 0x61334d50[!!] ERROR: cannot communicate with the Proxmark 

I realized later that the device is not enumerated correctly and it gets disconnected even though I removed ModemManager. After searching here and there I tried button trick to flash the device as follows:

  1. press button and keep it pressed (IMPORTANT)

  2. plug in device

  3. run flash command sudo client/flasher /dev/ttyACM0 armsrc/obj/fullimage.elf

  4. wait until flash is finished.

  5. release button.

And the method was successful, but when I unplugged and re plugged it again, ran the client, it could not find the device on the port. So I checked, the enumeration problem still presists.

What am I missing here or doing wrong? yikes


I need help as this is maybe the third time this happens.  yikes

Your help is much appreciated. Thanks! big_smile

Last edited by Hala (2019-10-22 11:03:07)

Offline

#2 2019-10-21 19:32:40

iceman
Administrator
Registered: 2013-04-25
Posts: 5,879
Website

Re: [SOLVED] Flashing to newest firmware issue

That would be the correct way to update it.   However did you compile the repo for your device?  If you have a RDV4, nothing extra to do,   if you have other proxmark3 device you will need to follow instructions https://github.com/RfidResearchGroup/pr … ameters.md


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#3 2019-10-22 11:02:41

Hala
Contributor
Registered: 2019-09-11
Posts: 3

Re: [SOLVED] Flashing to newest firmware issue

Yes its not an RDV4, I missed that! Followed the instructions in the link and It's working now, thanks a lot!

Offline

Board footer

Powered by FluxBB