Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2019-05-20 15:14:30

phantasmthewhite
Contributor
Registered: 2019-05-20
Posts: 3

Trying to flash iceman

Hello everyone!

I'm using a PM3 RDV4 which was shipped with an older version of the bootrom and OS, and it wouldn't work with Iceman's fork, so I'm trying to flash it to the most recent version. In order to do that I followed the Wikis and tutorials, everything was fine until I entered the command below:

phantasm@phantasmrogue:/usr/bin/proxmark3/client$ sudo ./flasher /dev/ttyACM0 -b ../armsrc/obj/fullimage.elf 
Loading ELF file '../armsrc/obj/fullimage.elf'...
Loading usable ELF segments:
0: V 0x00102000 P 0x00102000 (0x00037148->0x00037148) [R X] @0x94
1: V 0x00200000 P 0x00139148 (0x00001300->0x00001300) [RW ] @0x371dc
Note: Extending previous segment from 0x37148 to 0x38448 bytes

.Waiting for Proxmark to appear on /dev/ttyACM0.......... Found.

Flashing...
Writing segments for file: ../armsrc/obj/fullimage.elf
 0x00102000..0x0013a447 [0x38448 / 451 blocks]....................................................................................................

When I press the button and plug the PM3 in, it finds the PM3, starts writing the ELF file and goes through a line and half of dots dots dots, then stops, and nothing happens it just freezes like that forever...
Now when I try to plug my Proxmark, the "C" LED is on and the device is not detected properly anymore.

Here is the output of a dmesg command:

[18866.085978] usb 1-4: device descriptor read/64, error -71
[18883.130329] usb 1-4: new full-speed USB device number 113 using xhci_hcd
[18900.030691] usb 1-4: new full-speed USB device number 114 using xhci_hcd
[18916.927035] usb 1-4: new full-speed USB device number 115 using xhci_hcd

As you can see below, the first command to flash the bootrom worker perfectly:

 [ ARM ]
 bootrom: iceman/master/ice_v3.1.0-891-g6967fe66-dirty-unclean 2018-06-26 09:52:13
      os: iceman// 2018-06-26 09:54:28

Is my device bricked? :'(
Anyone to get me out of my troubles by any chance ?

Thank you very much

PS: Sorry if the case has been solved before, I googled and went through forum and couldn't find a working solution so far...

Last edited by phantasmthewhite (2019-05-20 15:15:33)

Offline

#2 2019-05-20 15:20:20

phantasmthewhite
Contributor
Registered: 2019-05-20
Posts: 3

Re: Trying to flash iceman

Nvm you can delete that post, I'm a monkey, the solution was given here:

http://www.proxmark.org/forum/viewtopic.php?id=6480

Offline

Board footer

Powered by FluxBB