Proxmark3 community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.

"Learn the tools of the trade the hard way." +Fravia

You are not logged in.


Time changes and with it the technology
Proxmark3 @ discord

Users of this forum, please be aware that information stored on this site is not private.

#1 2024-02-11 05:58:22

Registered: 2024-02-10
Posts: 2

How to fix Lock Error?


I recently updated to the latest version of the Iceman PM3 fork and tried to update my PM3 using MacOS.  I get the following error:

[+] Waiting for Proxmark3 to appear on /dev/tty.usbmodemiceman1
?  59 found
[=] Available memory on this board: 512K bytes

[=] Permitted flash range: 0x00102000-0x00180000
[+] Loading usable ELF segments:
[+]    0: V 0x00102000 P 0x00102000 (0x0004b51c->0x0004b51c) [R X] @0x98
[+]    1: V 0x00200000 P 0x0014d51c (0x00001c94->0x00001c94) [R X] @0x4b5b8
[=] Note: Extending previous segment from 0x4b51c to 0x4d1b0 bytes

[+] Flashing...
[+] Writing segments for file: fullimage.elf
[+]  0x00102000..0x0014f1af [0x4d1b0 / 617 blocks]
................[!!] ? Error: Unexpected reply 0x00fe NACK (expected ACK)
       Lock Error

       Lock Bits:      0x3352
[!!] ? Error writing block 16 of 617
[!] ⚠️  The flashing procedure failed, follow the suggested steps!
[+] All done

[=] Have a nice day!

Any idea how to recover from this?  I couldn't find any information about how or why lock bits are being set on the device.  I tried downloading and flashing a precompiled build.  That wouldn't work automatically; I had to use --force to get the bootloader on there and when I try to flash the full image, I run into the lock bits error again.

Am I missing something simple here?


Board footer

Powered by FluxBB