Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2020-01-14 06:05:00

Solon
Contributor
Registered: 2020-01-08
Posts: 6

Un-bricking Proxmark3 RDV4.01 - (flash error -71, all lights on)

Hello all,
Yes, i have managed to do the unthinkable, after so much excitement to use the proxmark, and all the wait time....
I managed to brick my device on the very first use, while attempting to flash it.

:'-(

I did virtually the same thing as user Riffruepel on this post:
http://www.proxmark.org/forum/viewtopic.php?id=6408


Sorry it was a few days ago now, so my documentation of the event is a little vague...but here goes.
I followed the instructions for Kali linux as per:
https://github.com/Proxmark/proxmark3/wiki/Kali-Linux

and did not see the part about disabling the modem-manager until i got to

./flasher /dev/ttyACM0 -b ../bootrom/obj/bootrom.elf
(at this point i think it broke)

*tried button trick
*tried upgrade full image

but to no avail, every time i plug in the device with button pressed or without, all the lights stay on. and the

dmesg output is: 
------------------

[ 4085.067944] usb 2-4: reset full-speed USB device number 2 using xhci_hcd
[ 5218.338297] usb 2-4: USB disconnect, device number 2
[ 5234.603640] usb 2-3: new full-speed USB device number 5 using xhci_hcd
[ 5234.731674] usb 2-3: device descriptor read/64, error -71
[ 5234.967662] usb 2-3: device descriptor read/64, error -71
[ 5235.203639] usb 2-3: new full-speed USB device number 6 using xhci_hcd
[ 5235.331670] usb 2-3: device descriptor read/64, error -71
[ 5235.567663] usb 2-3: device descriptor read/64, error -71
[ 5235.675720] usb usb2-port3: attempt power cycle
[ 5236.327640] usb 2-3: new full-speed USB device number 7 using xhci_hcd
[ 5236.327824] usb 2-3: Device not responding to setup address.
[ 5236.535825] usb 2-3: Device not responding to setup address.
[ 5236.743634] usb 2-3: device not accepting address 7, error -71
[ 5236.871641] usb 2-3: new full-speed USB device number 8 using xhci_hcd
[ 5236.871826] usb 2-3: Device not responding to setup address.
[ 5237.079816] usb 2-3: Device not responding to setup address.
[ 5237.287634] usb 2-3: device not accepting address 8, error -71
[ 5237.287749] usb usb2-port3: unable to enumerate USB device
[ 5506.203787] [drm] PCIE gen 3 link speeds already enabled
[ 5506.211307] [drm] PCIE GART of 2048M enabled (table at 0x00000000001D600

-------------------------------------------------------------------------

I saw that Riffruepel fixed it with a "Jegger Link" & "Proxmark Adappter" (post #12, in above link)
He said he would post a guide as to how he did it but never did.
Has anyone else solved this problem?
If so any help would be appreciated.
I ordered the above adapters, and they should be here in about a week, 
but at this point i can't even see where they would plug in.
I'll be updating this post to document my progress for future reference.
Kind Regards,
Solon.

For future reference this is the correct J-Tag port on the RDV4.01
Proxmark3 RDV4.01 Jtag

This is the FPC connector:
EDIT: This is what i thought was the JTAG port, but this is NOT correct.

Proxmark3 RDV4.01 Jtag


Thanks to:
Riffruepel
&
Iceman
will keep everyone posted on my developments...

Appendix:
----------
For the next Person who this happens to, below I will post some of the research I've found so far related to this issue:

RDV4 helper scripts for JTAG flashing
https://github.com/RfidResearchGroup/pr … g_notes.md

J-link pinout:
https://www.segger.com/products/debug-p … scription/

Jtag adapter for proxmark 3
https://github.com/RfidResearchGroup/pr … ag-adapter
https://github.com/RfidResearchGroup/pr … ag-adapter

Last edited by Solon (2020-01-20 10:07:44)

Offline

#2 2020-01-16 11:55:08

Riffruepel
Contributor
From: Germany
Registered: 2019-04-17
Posts: 17

Re: Un-bricking Proxmark3 RDV4.01 - (flash error -71, all lights on)

Hello Solon,

follow the link works great.

https://github.com/Proxmark/proxmark3/w … ing-Segger

Greetings Riffruepel

Offline

#3 2020-01-19 21:38:53

Solon
Contributor
Registered: 2020-01-08
Posts: 6

Re: Un-bricking Proxmark3 RDV4.01 - (flash error -71, all lights on)

.

Last edited by Solon (2020-01-20 10:08:15)

Offline

#4 2020-01-19 21:43:37

iceman
Administrator
Registered: 2013-04-25
Posts: 6,175
Website

Re: Un-bricking Proxmark3 RDV4.01 - (flash error -71, all lights on)

That would be the FPC connector you have marked.

If you remove the lower part of the plastic case,  you will find it easier,  but the six tiny holes on the opposite from where you marked....


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#5 2020-01-19 22:08:22

Solon
Contributor
Registered: 2020-01-08
Posts: 6

Re: Un-bricking Proxmark3 RDV4.01 - (flash error -71, all lights on)

.

Last edited by Solon (2020-01-20 10:50:47)

Offline

#6 2020-01-20 07:20:27

iceman
Administrator
Registered: 2013-04-25
Posts: 6,175
Website

Re: Un-bricking Proxmark3 RDV4.01 - (flash error -71, all lights on)

Yes,  that is the right spot.
If you edit your first picture post again and write that its the FPC connector,  it will be helpful.

You could also add this last picture in same post.


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#7 2020-02-08 18:07:20

zavidos
Contributor
Registered: 2019-07-17
Posts: 10

Re: Un-bricking Proxmark3 RDV4.01 - (flash error -71, all lights on)

I'm in the same situation, tried to write bootloader and firmware of regular proxmark on an RDV4 (because I wasn't able to read with sriread command). After this command

client/flasher /dev/ttyACM0 -b bootrom/obj/bootrom.elf armsrc/obj/fullimage.elf

it remained searching for proxmark, all lights are on, button trick doesn't work and it is not seen from pc (under ubuntu and osx).
I will order a j-link clone and try with it, do you think this is the proper object i need? https://www.amazon.it/Downloader-emulat … =8-1-fkmr1

thank you for your help

Offline

#8 2020-02-08 20:20:31

fazer
Contributor
Registered: 2019-03-02
Posts: 43

Re: Un-bricking Proxmark3 RDV4.01 - (flash error -71, all lights on)

Good evening Zavidos, looked here you will also find your happiness.
https://lab401.com/search?type=product&q=jlink

Offline

#9 2020-02-21 03:34:41

Solon
Contributor
Registered: 2020-01-08
Posts: 6

Re: Un-bricking Proxmark3 RDV4.01 - (flash error -71, all lights on)

Hello all, here is an update, I finally got my adapter in the mail and started to try this unbricking again.
Once I made the bin files I entered the following commands

  
$ wget https://www.segger.com/downloads/jlink/JLink_Linux_x86_64.deb
$ dpkg -i /path/to/JLink_Linux_x86_64.deb
$ JLinkExe 
J-Link> exec device = AT91SAM7S256
J-Link> exec EnableFlashDL
J-Link> h
J-Link> loadbin "/full/path/to/proxmark3_recovery.bin" 0x100000
J-Link> loadbin "/home/x/Shared/bootrom.bin" 0x100000
J-Link> loadbin "/home/x/Shared/fullimage.bin" 0x102000

Then I was met with this:
Proxmark3 RDV4.01 Flashed

Success! (Or so I thought)
I then plugged the Proxmark back into the USB port
and got this from "dmesg"
Proxmark3 RDV4.01 NoRec

Tried the process again and got

 
J-Link>loadbin "/home/x/Shared/proxmark3_recovery.bin" 0x100000
Downloading file [/home/x/Shared/proxmark3_recovery.bin]...
Comparing flash   [100%] Done.
J-Link: Flash download: Bank 0 @ 0x00100000: Skipped. Contents already match
O.K.

Any ideas on where to go from here?

Offline

Board footer

Powered by FluxBB