Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2019-08-13 21:22:27

l07tb0y
Contributor
Registered: 2019-08-12
Posts: 8

Cant get the bluetooth module to work

So I think I read the forums and the manual and it says the following should get the bluetooth module working but I can't get it to run

brew install --with-blueshark proxmark3
Error: rfidresearchgroup/proxmark3/proxmark3 is a head-only formula
Install with `brew install --HEAD rfidresearchgroup/proxmark3/proxmark3`
[=] Using UART port /dev/tty.usbmodemiceman1           
[=] Communicating with PM3 over USB-CDC           

 [ Proxmark3 RFID instrument ] 
          

 [ CLIENT ]          
  client: RRG/Iceman          
  compiled with Clang/LLVM 4.2.1 Compatible Apple LLVM 10.0.1 (clang-1001.0.46.4)          

 [ PROXMARK RDV4 ]          
  external flash:                  present           
  smartcard reader:                present           

 [ PROXMARK RDV4 Extras ]          
  FPC USART for BT add-on support: absent           
          
 [ ARM ]
  bootrom: RRG/Iceman/master/47b60d8 2019-08-11 21:49:19
       os: RRG/Iceman/master/47b60d8 2019-08-11 21:49:32
  compiled with GCC 5.4.1 20160919 (release) [ARM/embedded-5-branch revision 240496]

 [ FPGA ]
  LF image built for 2s30vq100 on 2019/ 7/31 at 15:57:16
  HF image built for 2s30vq100 on 2018/ 9/ 3 at 21:40:23          

 [ Hardware ]           
  --= uC: AT91SAM7S512 Rev B          
  --= Embedded Processor: ARM7TDMI          
  --= Nonvolatile Program Memory Size: 512K bytes, Used: 271172 bytes (52%) Free: 253116 bytes (48%)          
  --= Second Nonvolatile Program Memory Size: None          
  --= Internal SRAM Size: 64K bytes          
  --= Architecture Identifier: AT91SAM7Sxx Series          
  --= Nonvolatile Program Memory Type: Embedded Flash Memory          

          
[usb] pm3 --> 

tried the following as well

brew install --with-blueshark --HEAD rfidresearchgroup/proxmark3/proxmark3
Warning: rfidresearchgroup/proxmark3/proxmark3 HEAD-47b60d8 is already installed and up-to-date
To reinstall HEAD, run `brew reinstall proxmark3`

Offline

#2 2019-08-14 02:55:35

bettse
Contributor
From: Portland, OR, USA
Registered: 2015-02-16
Posts: 31

Re: Cant get the bluetooth module to work

When you run `brew install ...` do you see

==> make all PLATFORM_EXTRAS=BTADDON

(specifically the PLATFORM_EXTRAS bit)?

I _had_ it working (at least showing 'present' instead of 'absent'), but when I tried to update the client (and flash the firmware to match) I ended up with my own problems.

Offline

#3 2019-08-14 21:39:04

iceman
Administrator
Registered: 2013-04-25
Posts: 5,595
Website

Re: Cant get the bluetooth module to work


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Online

Board footer

Powered by FluxBB