Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2013-03-19 19:38:15

LawPoh
Member
Registered: 2013-03-19
Posts: 8

com port of pm3 cannot be found in device manager

I am having a problem even trying to run proxmark.exe.

It is asking me for the serial port which is not listed within my device manager as shown below:

syntax: proxmark3.exe <port>

3192013110400pm.jpg


I think it is because of the serial port issue, I cant seem to be able to flash the fpga and OS.

Can someone help me out on this please?

Offline

#2 2013-03-19 21:07:11

rule
Administrator
Registered: 2008-05-21
Posts: 416

Re: com port of pm3 cannot be found in device manager

Please hold the button and replug your Proxmark. Look at the device manager and use the ../trunk/driver/proxmark3.inf file to install the proxmark as a COM-port. If everything is correct, you are still holding the button. You should be able to flash the osimage and fpga now with the COM-port you find in the device manager.

Please do NOT double post!!!!!

Offline

#3 2013-03-20 03:05:14

LawPoh
Member
Registered: 2013-03-19
Posts: 8

Re: com port of pm3 cannot be found in device manager

Apologies on the double post.

Thanks roel.  That certainly solves it.

proxmark3> hw ver
#db# Prox/RFID mark3 RFID instrument
#db# bootrom: svn 681 2013-03-18 19:46:19
#db# os: svn 681 2013-03-18 19:46:24
#db# FPGA image built on 2012/ 1/ 6 at 15:27:56
proxmark3>

Offline

#4 2013-04-08 10:12:44

homer999
Member
Registered: 2012-05-07
Posts: 3

Re: com port of pm3 cannot be found in device manager

I got similar problem with Windows 7 driver. I have install it as suggested via trunk driver (ver 695). Installation fails with "This device cannot start. (Code 10)". Re-install couple of times, but no change. Can you please advise?

Cheers,
Mike

Offline

#5 2013-04-18 16:01:43

robsoninc
Member
From: Vancouver, BC
Registered: 2013-04-18
Posts: 5

Re: com port of pm3 cannot be found in device manager

I had some Windows 7 issues. This is what I did. (if I remember correctly.. at the very least it should point you in the right direction)

1) Remove the legacy USB drivers. (Make sure it does not come up as the proxmac device.)
2) Unplug the proxmark. Hold the button the on proxmark and while still holding it plug it back in to your computer.
3) While still holding it, select Human Interface Devices, and check which USB Input Device is the Proxmark. (Should be able to go to details and look at the bus name/description) ** Still Holding the button on the Proxmark**
4) Update the drive for the USB Interface to the new Proxmark INF file for the COM port.
5) You should see the proxmark come up in the device manager as a COM device. Note the COM port and flash the device.

Once it's flashed it should come up with the right port. Different USB ports will be different COM ports, so update any BAT files as nessesary.

Offline

#6 2013-05-05 05:33:58

homer999
Member
Registered: 2012-05-07
Posts: 3

Re: com port of pm3 cannot be found in device manager

I am still getting "This device cannot start. (Code 10)". Please advise what do I need to do to get the device running. The version command (Windows 7 with old driver) returns:

#db# Prox/RFID mark3 RFID instrument
#db# bootrom: svn 486-unclean 2011-08-28 18:52:03
#db# os: svn 650 2013-04-02 08:33:34
#db# FPGA image built on 2012/ 1/ 6 at 15:27:56

Offline

#7 2013-08-18 02:14:54

Bugman1400
Contributor
Registered: 2010-12-20
Posts: 132

Re: com port of pm3 cannot be found in device manager

I am still using Windows XP and cannot get my PM3 to show up as a COM port.


ndts.png

I have tried to uninstall and re-install the PM3 driver but, I get the Windows error message "The specified location does not contain information about your hardware".

I have been away for a while but, the last time I used my PM3 I did not have to use the command syntax "proxmark3.exe <port>". I can't remember what SVN I was but, I think it was below 500. Should I try an earlier Proxspace version?

How does Windows XP, Vista, 7 or whatever recognize a piece of hardware? Can I change the verbiage of what shows up in Device Manager as "HID-compliant device" to something else?

Thanks!

Offline

#8 2013-08-18 19:54:53

Bugman1400
Contributor
Registered: 2010-12-20
Posts: 132

Re: com port of pm3 cannot be found in device manager

I was able resolve part of the issue. First of all, I did not have any libusb drivers at all! So, I downloaded the latest and installed. That allowed the PM3 to show up as an libusb-win32 device instead of as a HID-compliant device:

mft2.jpg

However, it still does not show up as a registered COM device but, I was able to use an older version of proxmark3.exe to communicate with my PM3. You can see that my SVN is 498!

Offline

#9 2013-08-18 19:57:43

midnitesnake
Contributor
Registered: 2012-05-11
Posts: 151

Re: com port of pm3 cannot be found in device manager

The old bootloader/os (prior 652) comes up as a HID (libusb) device.  So its all working now smile

If you want to update your bootloader and os to the latest version; then it will turn into a COM device (rather than the USB).

Offline

Board footer

Powered by FluxBB